User Tools

Site Tools


computing:compilers:codeblocks

Code::Blocks

Code::Blocks comes with no compiler; it's a bare IDE.

How to install the latest stable version, has some GNU/Linux distribution does feature an older one.

For (K)unbuntu (Debian), download the corresponding archive on the official web site, which contains several .deb package. The mandatory ones seem to be:

  1. codeblocks_17.12-1_amd64.deb,
  2. codeblocks-common_17.12-1_all.deb,
  3. codeblocks-contrib_17.12-1_amd64.deb
  4. codeblocks-contrib-common_17.12-1_all.deb.
computing/compilers/codeblocks.txt · Last modified: Fri Dec 6 09:12:57 2019 (06/12/19) by Claude SIMON